Forumet - Uppdaterings samt -bootproblem (Debian)

Uppdaterings samt -bootproblem (Debian)

281 0 29
Hej.

Jo, det är som så att jag inte kan uppdatera mitt system. Jag har försökt via Pakethanteraren och via terminalen, men det går inte.

Får följande felmeddelande: E: Dynamic MMap ran out of room

Jag googlade runt lite och fann lite svar, som jag föörsökte mig på, men utan resultat.

Jag blev då less på det och laddade ner den nya utgåvan av Debian. Bränner skiten och bootar om för att installera skiten. Men det fungerade inte heller. Ändrade så att den skulle boota från skivan, men detta fungerade inte heller.

Får bara upp ett meddelande vid start; System monitor found an error. Eller hur det nu löd, något liknande iaf.

Någon som vet var felet kan ligga?

Spana också in:

passaro:

Vad, exakt är det man ändrar i den? Finns flera olika rader där versionen Etch står, ändrar man det till det nya namnet, eller?


Ja du ändrar bara etch till lenny eller squeeze.
Efter du gjort det och sparat måste du köra en apt-get update.
Kom också ihåg att om du byter till sqeeze (testing) så ska du kommentera ut raderna med "security" för det finns inga säkerhets-repos för testing. Du bör kanske prova med lenny först, men squeeze har funkat fint för mig iaf.
lenny fungerar rätt bra, fakitskt. Men nu har jag ett litet skitproblem som är rätt så störande. Efter uppdateringen och omstart av datorn så ändrade skärmupplösningen sig. Nu är det på 1024x728 och mindre. Så allt är rätt stort.

Går inte att ändra via inställningarna. Kollat lite i xorg.conf för att se om det finns fler alterativ för skärmupplösningen och det gör det. Tänkte att det kanske berodde på gammal version av drivrutin till kortet, men den säger att jag redan har den nyaste versionen.

Någon som vet hur man åtgärdar detta? Börjar gå mig på nerverna.
passaro:

lenny fungerar rätt bra, fakitskt. Men nu har jag ett litet skitproblem som är rätt så störande. Efter uppdateringen och omstart av datorn så ändrade skärmupplösningen sig. Nu är det på 1024x728 och mindre. Så allt är rätt stort.


Öppna en terminal och kör xrandr, där ser du vilka upplösningar som finns tillgängliga för tillfället.
aristoteles:

Öppna en terminal och kör xrandr, där ser du vilka upplösningar som finns tillgängliga för tillfället.


   1600x1200      
1400x1050
1280x1024
1024x768
800x600
640x480
640x400
320x400
320x240
320x200


Har haft fler upplösningar innan. Blir inte alls bra med någon av dem.
aristoteles:

I din /etc/X11/xorg.conf står det "nvidia" på driver i sektionen "device"?


Står konstigt nog inget sådant nu. Men det gjorde det förut och då stod det nv17 på driver i sektionen 'device'. Tstade att ändra till 'nvidia' förut, men då kunde inte X starta alls.

Nu ser det ut så här:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

aristoteles:

Prova #modprobe nvidia


Skriva in det i xorg.conf?



aristoteles:

Är du säker på att installationen gick bra? Klagade den på kernel-headers eller liknande?


Den klagade på att den inte hittade någon kernel så att den fick konfigruera en från början, eller något i den stilen.
passaro:

Skriva in det i xorg.conf?


Kör som kommando. Kommandot modprobe laddar en kärnmodul och de dependencies som modulen eventuellt har.

passaro:

Den klagade på att den inte hittade någon kernel så att den fick konfigruera en från början, eller något i den stilen.


Det brukar funka för mig, att det kompilerar en grund alltså. Hmm.

Om moduler inte heter nvidia så kan du köra
#modprobe -l | grep nvidia
så hittar du den kanske.